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System Overview 

MatrixStore InterConnect is a Windows service which allows Avid Interplay users to archive 

assets and their associated media to MatrixStore nearline storage, and restore them at a 

later date, without requiring the Interplay Archive Engine. Most operations are performed 

simply by drag-and-drop in the Folders pane of Interplay Access. 

Requirements 

 A Windows machine (32- or 64-bit) on which to install InterConnect. 

 Avid Interplay, version 1.4 or higher. 

 Avid Interplay Web Services, version 2.4 or higher. 

 A MatrixStore cluster, version 2.7 or higher. 

 The MatrixStore client tools MXFS and DropSpot ; these are optional but highly 

recommended for maintenance operations. 

 The MatrixStore LTO service, if you want automatic retrieval of objects from LTO 

tape. 

If you don’t currently use the Interplay Web Services, you may wish to install them on the 
machine where you’re installing InterConnect. Note that you can have multiple instances of 
the Web Services on different machines. 

Where to Install 

InterConnect can be installed on any Windows machine as long as it has network 
connections to: 
 

 The host running the Interplay Web Services. 

 The Avid shared storage device(s) from which media is to be archived. 

 The MatrixStore cluster to be used for archiving. 

 The MatrixStore LTO service, if required. 

For small installations and demo setups, install InterConnect on a Windows editing client 
machine. For larger installations use any suitable server, eg. the Media Services engine.  
 
The network card used to connect to Avid storage must be of a sufficiently high spec as to 
allow the transfer of media files (Avid recommend the Intel PRO/1000). To test the transfer, 
simply try to drag and drop a large MXF media file from storage to the desktop. 

The InterConnect Monitor 

The InterConnect Monitor lets users view the status of the InterConnect service, including 
the progress of any assets being copied, from a remote machine. 
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After installing the service, you can install the monitor on any number of Windows machines 
on the same network as the service. 

The InterConnect Administration Tool 

This tool is used by administrators to configure and maintain the installation; it also 
performs all the functions of the InterConnect Monitor. 
 
It is automatically installed on the machine where you install the service;  you can install 
additional copies of this tool on any number of Windows machines on the same network as 
the service. 

Installing InterConnect on Multiple Servers 

It may be useful to install InterConnect on two or more servers for one of two reasons: 
 

 If you have multiple Interplay engines, you could use a separate instance of 
InterConnect to service each one. 

 If you use multiple vaults, you can distribute the I/O load by having separate 
instances of InterConnect, each one working on just a single vault. 

 In case your primary InterConnect server goes down, you can have a second one 
standing by, with the service left in its unstarted state. The second server must have 
the same configuration as the primary server, so if the configuration changes you 
must manually copy config.txt to the secondary server. 

 

You must not have two active instances of the service watching the same folders; this may 

give unexpected results. 
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Upgrading an Existing Installation 

Upgrading the InterConnect Service 

First check that no jobs are in progress. Then just run the supplied Windows installer 
program InterConnect.msi  (InterConnect64.msi for a 64-bit machine) on the machine where 
the service is installed; it will detect the old version and replace the old files with new ones. 
 
After installation you will have to restart the service manually. 
 
Upgrading will preserve your existing configuration, including all history and log files and the 
Windows service configuration. 
 
From InterConnect 2.2, logs and config files are no longer held in C:\Program Files, but in: 

 C:\ProgramData\Object Matrix\InterConnect        (Windows 7) 
 C:\Documents and Settings\All Users\Object Matrix\InterConnect (XP) 

 
The installer will copy your existing data to the new location, and you can delete the old data 
afterwards if you wish. 

Upgrading Remote Administration Tools and Monitors 

If you have additional copies of the InterConnect Monitor or InterConnect Administration 
Tool installed on any remote machines, you will need to upgrade them to the new version by 
running the separate installer on each machine in turn; older versions will not be able to 
communicate with the new service. 
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Preparing Interplay for use with 
InterConnect 

Note that it is not necessary to stop using Interplay during installation of InterConnect. 
However, you may wish to take this opportunity to take a backup of the Interplay database. 
 

Creating Watched Folders 

Log on to Interplay Access as an Interplay administrator and create a top-level folder1 in the 

Interplay database called MatrixStore, with subfolders called Archived, Restored, To Be 
Archived and To Be Restored: 
 

 
 

Optionally, you can also create subfolders called Deleted and To Be Deleted, if you want to 
be able to delete assets from MatrixStore from inside Interplay Access. 
 
All these folders can have any other names, but they must match exactly the names that you 
enter into the InterConnect configuration dialog. 
 
The Interplay user that you choose for the InterConnect service to log on as must have full 
permission for these folders, including the ability to create subfolders. 
 
You can create multiple sets of folders and assign each to a different vault, eg: 
 

                                                           
1
 If you can’t create top-level folders, you need to right-click on the database, choose “Security” and 

check the box marked “Allow creation of sub-folders”. If you don’t see the “Security” item on the right-
click menu, you need to use the “Preferences” menu and check the box marked “Full Menus”. 
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You can then use the “Manage Database Roles” screen in Interplay Administrator to restrict 
access to these folders to particular users. 

Creating Multiple “To Be Restored” Folders 

You can create multiple To Be Restored folders for a single vault, each of which is 

configured to restore the media to a different workspace. For instance, dragging to To Be 
Restored could restore the media back to its original workspace, dragging to To Be 
Restored – workspace2 could restore the media to “workspace2”. 
 
See “Choosing the Workspace for Restored Media” later in this guide. 

Creating Subfolders in Watched Folders 

You can switch on an option which lets you create logical subdivisions in an archive by 
creating subfolders in the To Be Archived folder. See “Choosing the Interplay Folders” later 
in this guide. 

Creating the MatrixStore Status Column 

Once you have created all necessary folders, run Interplay Administrator and edit the 
properties of the database, adding a new column called MatrixStore status (Site Settings > 
Property Layout > Custom Metadata). 
 
Note that all these names are case-sensitive. 
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Installing the InterConnect Service 

Running the Installation Program 

Log on to the chosen Windows machine as an administrator, then run the supplied Windows 
installer program InterConnect.msi (InterConnect64.msi for a 64-bit machine); this installs 
InterConnect in the following location: 
 

C:\Program Files\Object Matrix Ltd\InterConnect 

 
About 70MB of disk space is needed. 
 
It also creates the following folder for data used by InterConnect: 
 

 C:\ProgramData\Object Matrix\InterConnect        (Windows 7) 
 C:\Documents and Settings\All Users\Object Matrix\InterConnect (XP) 

 
The InterConnect Administration tool is also installed along with the service; a shortcut to 
this program is created on the desktop, and an entry for it is created in the Windows Start 
menu. 

Choosing the Username for the Windows Service 

You must choose a suitable Windows username for the InterConnect service to log on as: 

 This user must be able to access (read/write) all workspaces which will be used for 
archiving, ie. it must be set up as a user on every workspace, just like an editor user. 

 The user must have access (read/write/modify) to the InterConnect installation 
directory, or it will not be able to maintain its log files and job history. 

 The user must have a password, or the service wil not start. 

Windows Service Parameters 

The installer program creates a Windows service called “InterConnectService” which must 
be configured using Control Panel > Administrative Tools > Services. 
 
Find “InterConnectService” in the list of services, double-click it and change the following 
settings: 
 

 In the “Log On” tab, you must replace the default “Local Service” account with the 
chosen username and password.  

 

 In the “General” tab, change the Startup Type from Manual to Automatic. 
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 If the Avid Interplay Web Services are running on the same machine as the 
InterConnect service, you should ensure that the Web Services start up first by 
adding “InterplayWS” as a dependency using this DOS command: 
 

sc config interconnectservice depend= interplayws 

 
(This command requires a space after the equals sign but none before it. The service 
names are not case-sensitive).  

Using a Different Port 

By default, the service uses port 8082 to communicate with its admin tool and monitor 
clients. If this port is being used by other applications, give a different port number by 
creating this text file: 
 
C:\ProgramData\Object Matrix\InterConnect\serviceargs.txt (Windows 7) 
C:\Documents and Settings\All Users\Object Matrix\InterConnect\serviceargs.txt (XP) 
 
containing the line “-port n”, where n is the port number to be used. 

Starting and Stopping the InterConnect Service 

Now press the ”Start” button; the service will now run in the background, even when you 
log off, and will start up automatically whenever the machine is rebooted. Should you wish 
to stop the service, you can double-click it and use Stop. 
 
If this is a new installation, you must now create the configuration by running the 
InterConnect administration tool. This will prompt you through the process of creating the 
configuration using the dialogs described under “Configuring InterConnect” in this guide. 
 

Removing the Installation 

To completely remove InterConnect from a machine do as follows: 

 Remove the registry entry for the service with the DOS command “sc delete 
interconnectservice”. 

 Remove the installed files using Control Panel > Programs and Features (Add or 
Remove Programs under Windows XP) or the “Uninstall” link in the Windows Start 
menu. 

 Remove all user files by deleting all files in these folders using Windows Explorer: 

C:\Program Files\Object Matrix Ltd\InterConnect 

 C:\ProgramData\Object Matrix\InterConnect        (Windows 7) 
 C:\Documents and Settings\All Users\Object Matrix\InterConnect (XP) 
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Configuring Connections 

You create or change the InterConnect configuration by running the InterConnect 
administration tool and using the “Configure” menu. The InterConnect service and the 
Interplay Web Services should both be running while you are doing this. 
 
If you’re using Unity MediaNetwork storage which is fibre-attached to the Interplay server, 
you then need to complete the configuration by manually editing the configuration file (see 
appendix). 

Connect to the Service 

First use the File > Connect to Service menu item: 
 

 
 
Type in the name or IP address of the machine where InterConnect is running, and the port 
number it is using to communicate with its GUI clients (the default is 8082), then press “OK”. 

Configure Connection to Interplay 

Then use the Configure > Connection to Interplay menu item: 
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You must fill in the following fields: 
 
Endpoint the hostname or IP address of the machine running the Interplay Web 

Services at your site, including the port number if the Web Services aren’t 
using the default HTTP port (80). 
 

Workgroup  the name of the Avid Interplay workgroup to be watched. You can find this 
by right-clicking the database in Interplay Access and using “Avid Workgroup 
Properties”. Alternatively, press the “Edit” button to choose from a list of all 
workgroups. 

 
Username  the Interplay username to be used when accessing the Web Services. This 
   must have sufficient privilege to create directories in the watched folders. 
 
Password  the password for this username. 
 
The “Test” button verifies that the Web Services can be accessed using the parameters 
specified on this screen. 

Configure Connection to LTO Service 

The Object Matrix LTO service lets you archive objects from a vault to an LTO tape, and 
optionally then make the objects offline in the vault to save space (in which case they 
appear as zero-size “stubs” ).  
 
If any objects in an InterConnect archive are stubbed out in this way, the data needs to be 
retrieved from LTO tape before it can be restored to Avid storage. If you want InterConnect 
to do this automatically when you try to restored a stubbed-out asset,  first make sure that 
the LTO service is running, then use the Configure > Connection to LTO menu item: 
 

 
 
Simply check the Use the LTO service box and enter the hostname or IP address of the 
machine where the LTO service is running. If it isn’t using the default port number for 
communications (8084), you must also enter this. When you press OK the admin tool will try 
to validate these by connecting to the LTO service. 
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Configuring Archives 

The Configure > Archives menu item lets you specify which Interplay folders are to be 
watched, which MatrixStore vault is to be used for archiving, which media formats to archive 
for this vault and whether to delete media from the Avid workspace after archiving. 
 
To define additional archives, press the “New” button. 
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Choosing the Interplay Folders 

You must supply the names of the Archived, Restored, To Be Archived and To Be Restored 
folders for this archive; double-click in the correct row of the table and type in the new 
name. 
 
The entire path for each folder must be given, with slashes separating subfolder names. 
“/MatrixStore” denotes a top-level folder in the Interplay database (AvidWG). 
 
If these folders already exist, you must give their precise names (case-sensitive). Use the 
“Test” button to see if the folders exist – this gives you the option to create them if they 
don’t. 
 
If you have created subfolders inside any “To Be Archived” or “To Be Restored” folder, you 
must check the “Leave empty subfolders in watched folders” box in the Configure > Options 
menu, or those subfolders will be deleted the first time the folder is watched. 

Choosing the Workspace for Restored Media 

By default, media files for assets that are dragged to the “To Be Restored” folder are 
restored back to same workspace(s) they were on  when they were archived. 
 
To specify a different workspace, select the row for the folder, right-click and choose 
“Change Workspace”. You can then browse to a workspace or type in its UNC path. 
 
If you want to let the user choose which workspace to restore to, you can use the “Add” 
button to create extra “To Be Restored” folders (giving each one a unique name) and set a 
different workspace for each folder. 

Choosing the Vault 

You must supply a .vault file for every archive (these files are created by the MatrixStore 
Administration tool). The file you select is copied to the program data directory. 
 
You must also specify a  root directory for the archive in the vault; this will be created if it 
doesn’t exist. For instance, “/Archive” will keep all archived assets inside a top-level 
directory called “Archive”. 
 
You can have multiple archives using the same vault, if they must share the same .vault file 
and have different root directories. However, you are recommended to use a different vault 
for each archive if possible. 

Choosing Which Resolution(s) to Archive 

Formats to Archive is an optional list of video formats which are to be archived. Items in the 
list can be the full name of a format (eg. “DNxHD-185x”) or use wildcards (eg. “*HD*”). Only 
formats which match an item in the list will be archived. If no list is specified, the default is 
to archive all formats which are online. All audio tracks are always archived. 
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Deleting Media from the Avid Workspace after Archiving 

Simply check the “Delete media after archive” box.  
 
All media files will then be deleted once they are successfully archived, unless: 

1) the asset is reserved, or 

2) the asset is used by a sequence which hasn’t been archived.2 
 
You can also enter a list of specific video formats to be deleted. Items in the list can be the 
full name of a format (eg. “DNxHD-185x”) or use wildcards (eg. “*HD*”). Only formats which 
match an item in the list will be deleted. Audio tracks will be deleted only if all video tracks 
are also deleted. 

Deleting Assets from the Vault after Restoring 

Simply check the “Delete assets after restore” box. Each asset will then be deleted from the 
vault after a successful restore, unless it’s used by another asset (eg. a sequence or subclip) 
which is still in the vault. 
 

                                                           
2
 A sequence is considered to be archived if it appears in any of the folders reserved for use by 

InterConnect, ie. all Archived/Restored/To Be Archived/To Be Restored folders, plus the temporary 
ARCHIVING/RESTORING folders created for each job. 
 
You can bypass this checking for sequences using the “Configure > Options” dialog: 
 

 
 
Unchecking “Check relatives before deleting media” will delete all media unless it’s reserved. 
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Extra Configuration Options 

Using Metadata 

By default, when an asset is archived the following searchable metadata keys are written to 
the vault, where applicable: 

Name Description 

Camera  

Comments  

Created By user name 

Creation Date eg. 2012-01-31T17:15:39.000+0000 

Initial Checkin Date eg. 2012-01-31T17:15:39.000+0000 

name Display name 

mediafiles Comma-separated list of .mxf files for masterclips 

Media Size Number of bytes 

Media Status eg. “online” 

mobid Unique id of an Avid asset 

Moniker Unique id of the asset link (used to identify non-Avid assets) 

Original Bin  

Original Machine Name  

Original Project  

Reel #  

Shoot Date  

Tape  

Type eg. “masterclip”, “sequence”, “PDF File” 

Video ID  

Workspace Location of media 

 

You can make InterConnect write additional keys, corresponding to any of the properties 
listed on the Property Layout screen in Interplay Administrator. These properties are divided 
into two tabs – System Properties for standard columns and Custom Metadata for user-
defined columns (the System Properties are also listed in the “System Metadata Properties” 
appendix to the Interplay Access User’s Guide). 

If you want to write any other keys, you must edit one of the supplied files in the 
”metadata” subfolder of the program data folder: 

system_properties.txt lists the system properties to be written  

custom_metadata.txt lists the custom metadata to be written. 
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The strings in system_properties.txt must be a subset of those listed in 
system_properties_1.txt and system_properties_2.txt. 

Note that by default custom_metadata.txt is empty, and no custom metadata is written. 
After changing these files, you must restart the service before the changes will take effect. 

 

Scheduling Watches 

By default, each folder is watched constantly, 24 hours a day. Whenever something new is 
found in one of these folders, a new job is started. 
 
Alternatively, you can specify that these folders are only watched at specific times of day; no 
new jobs will start outside these times. To specify a schedule for a folder, use the “Configure 
> Schedules” dialog: 
 

 
 

Choose a folder and press “Edit”. This displays the following dialog: 

 
 

This gives you the following options: 

 24/7 - the default watch, constantly, 24 hours a day, every day. 
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 Continuous - scan daily at regular intervals between start and finish times, excluding 
specific days of the week. 

 Specified Times - up to 4 times per day, excluding specific days of the week. 

 Custom - for more complex schedules (eg. scanning only on the first day of the 

month) you can specify a cron expression, without the seconds and years fields. See 

http://quartznet.sourceforge.net/tutorial/lesson_6.html. 

To watch a folder outside its normal schedule, use the “Configure > Schedules” menu, select 

the folder and press the “Check Now” button. 

Configure Error Levels 

You can specify the severity of certain error conditions. For instance, you can specify that 
attempting to archive an offline clip is OK and not an error; then no red X will be displayed 
for it. To specify error levels, use the Configure > Error Levels dialog: 

 

 
 
To change an error level, click on it in the “Level” column and use the dropdown list to 
change it to OK, WARNING or ERROR. Then press OK – the changes will be sent to the 
InterConnect service, if it’s connected. 

Configure Email Alerts 

You can configure InterConnect to send you an email if it detects a fatal error – for instance, 
if the machine running the service is rebooted while a job is in progress. Do this via the 
“Config > Email Alerts” menu item: 
 

http://quartznet.sourceforge.net/tutorial/lesson_6.html
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Use the “Test” button to send a test email using the values you have entered. 

Deleting from Vaults 

By default, InterConnect will not allow deletion from the vault of an asset that has any 
media offline in Interplay. To change this behaviour, use Delete > Options > Allow delete of 
offline assets: 
 

 
 

This allows deletion of all assets, regardless of their media status. 
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Installing the InterConnect Monitor 

The InterConnect Monitor lets you view the status of the InterConnect service, including the 
progress of any assets being copied, from a remote machine. 
 
It is similar to the InterConnect Administration tool but doesn’t allow the user to change the 
configuration. 
 
After installing the service, you can install the monitor on any number of Windows machines 
on the same network as the service. 
 
THERE’S NO NEED TO INSTALL THE MONITOR ON THE MACHINE WHERE THE SERVICE IS RUNNING, BECAUSE THE 

INTERCONNECT ADMINISTRATION TOOL DOES THE SAME JOB AS THE MONITOR. 

To install the monitor, first run InterConnectMonitor.msi (InterConnectMonitor64.msi for a 
64-bit machine) on the chosen client. 
 
The monitor must be configured with the hostname (or IP address) of the machine where 
the service is running, plus the port number used for communicating with it; the first time 
you run the monitor, it will ask you to provide this information. 
 
If you subsequently need to change the hostname or port, use the monitor’s “Configure> 
Connect to Service” menu. 
 
To uninstall the monitor, use Control Panel > Programs and Features (Add or Remove 
Programs  under Windows XP) or the “Uninstall” link in the Windows Start menu. 
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Appendix: Troubleshooting 

To see if the service is running, start up the InterConnect admin tool – this will give an error 
if it cannot connect to the service. 
 
If the service generated any errors or warnings, you can see them using the “View Log” 
button of the admin tool. 
 
Errors are also written to error.log in the program data directory. Further information will be 
found in the current log file, logs\iconnect.log. 
 
If the service can’t be started using the Windows Services menu, try querying its status from 
the Windows command line using the command “sc query interconnectservice”. If the 
service appears to be installed correctly, try starting the program from the command line by 
running the supplied file “runit.bat”:  runit –debug 
 

If you get the Windows error “Error 1: Incorrect function.” when starting the service, it 
probably means that the Java runtime is corrupted – verify this by trying to start the 
InterConnect admin tool, which uses the same Java runtime. 
 
You can switch debugging on using the Configure > Options menu of the InterConnect admin 
tool. Alternatively you can edit the configuration file config.txt and inserting the line 
<debug>true</debug>. 
 
Communication with the Interplay Web Services can be debugged by editing log4j.properties 

and changing the line log4j.rootLogger=WARN,A1 to read log4j.rootLogger=DEBUG,A1 . 
Debug information will be written to axis.log. 

 
You can check that the Assets service is available by browsing to 
http://<your.ip.address>/services and checking that it is listed there. You can test the 
connection to it by browsing to http://<your.ip.address> and using “Test Configuration”. 
 
If the service is running but failed to archive or restore a particular asset, you can check if 
there were any errors or warnings by running the admin tool, clicking on the job in the 
Completed Jobs list and clicking on the asset that failed. 
 
If there are timeouts or other errors accessing a workspace, check that the service user has 
access to the workspace. 
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Appendix: Fibre-Connected Storage 

If any of your media is on a Unity MediaNetwork storage device which is fibre-connected to 
the Interplay server, you need to manually edit the InterConnect configuration file. 
 
This file is called config.txt and is in the program data directory: 
 

 C:\ProgramData\Object Matrix\InterConnect        (Windows 7) 
 C:\Documents and Settings\All Users\Object Matrix\InterConnect (XP) 

 
Stop the service and, somewhere between the start and end <interconnect> tags in this file, 
insert a line of the form: 
 
   <unityname interplay=”unityfc” local=”unity” /> 

 

This maps the name by which the machine is known to Interplay (eg. UNITYFC) to the actual 
computer name (eg. UNITY). You can run the Connection Manager to find these names. Both 
names are case-insensitive. 
 
If there are additional Unity MediaNetwork machines which require archiving, add an extra 
<unityname> tag for each one. 
 
Then start the service again, and media on these workspaces will be available. 
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Appendix: Health Check of the 
Interplay Database 

It’s possible, though rare, for an asset to have a control character3 in its display name. 
 
Due to a problem with the Interplay Web Services, the contents of a watched folder cannot 
be read if any asset in that folder contains such a character. 
 
If InterConnect discovers such a folder inside one of its “To Be Archived” or “To Be Restored” 
folders, it writes an error message to its log and carries on, ignoring that folder. 
 
If this happens, you should identify the asset with the “bad” name and rename it (the 
control character shows up as a space in Interplay Access, but can be identified if you export 
the AAF file and examing it with Notepad). Restart the service and it will no longer ignore 
the folder. 
 
To discover all occurrences of such assets, use the “File > Health Check” menu of the 
InterConnect admin tool. Optionally type in the name of the root folder to check (eg. “/” for 
the whole database, “/Projects” for the top-level “Projects” folder) and press “Start”. 
 
This will display the names of any subfolders that can’t be read – note that it may take an 
hour or so to check a folder containing a large number of assets. 
 

                                                           
3
 A character with a Unicode value that is less than 32 decimal. 


